Symptom
During Salesforce integration, after the consumer secret and key are added and when you click on Authorize, a blank pop-up appears and on the address bar you will see an error that reads
Cause
- This could be happening because of the Salesforce connected app settings or the Hostname on the Pronto - Salesforce Authorization page.
Resolution
To resolve the issue, we need to edit the connected app settings on Salesforce.
- Login to Salesforce and click on Setup on the top right of the page.
- On the left sub-navigation, click on Apps and click on App Manager.
- Locate the connected app and click on the down arrow corresponding to the app and click on View or Edit.
- On the Edit window, scroll down to the section API (Enable OAuth Settings) and make sure that the below mentioned options are unchecked.
- Require Proof Key for Code Exchange (PKCE) Extension for Supported Authorization Flows
- Require Secret for Web Server Flow
- Require Secret for Refresh Token Flow
- Scroll down to the bottom and hit "Save".
- Once the Salesforce connected app settings are saved, go back to the Pronto application and refresh the page.
- Enter the connected app name
- Enter the consumer key and secret and try to authorize.
- If you are still seeing the same error pop-up, then we need to update the Hostname on the Salesforce Authorization page on Pronto.
- By default, you will see the hostname as https://login.salesforce.com. We need to change the hostname by copying the details from your Salesforce instance.
- Open you Salesforce application and click on the Profile icon on the top right of the page. Under the displayed name, you will see the hostname of the Salesforce edition that you are logged in. Double click on the address and copy the address.
- Paste the address in the hostname field and make sure that "https://" is added before the URL.
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