Symptoms
The SFDC filter is not pulling the correct opportunities.
Cause
This has NOT been validated by Engineering. During setup if a wrong filter is used, synced and then modified, then the wrong opportunities keep downloading even after deletion. Somehow the filter may be stuck with the wrong filter criteria.
Removing opportunities and removing accounts does not seem to help.
Resolution
- Delete the existing datasource listed in the relationship.
- Remove the existing Accounts/Opportunities
- Create a NEW datasource and new Filter
This can be tested first by creating a new "test" relationship with the correct filter. Later on the whole relationship can be deleted.
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